Devtools installation failed

Hi, I am pretty new to rstudio. Wanted to install devtools but it it shows an error which I dont understand. Would appreciate if someone could help.

Error: package or namespace load failed for ‘devtools’:
.onLoad failed in loadNamespace() for 'pkgload', details:
call: loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]])
error: namespace ‘rlang’ 0.4.12 is already loaded, but >= 1.0.1 is required
In addition: Warning message:
package ‘devtools’ was built under R version 4.1.3

Try to install through terminal...

:$ sudo su - -c "R -e \"install.packages('devtools', repos='', lib='/usr/lib/R/library', dependencies = TRUE, INSTALL_opts = '--no-lock')\""

Citation : Centos 'lib="/usr/local/lib64/R/library"'不可写 如何解决 - COS论坛 | 统计之都 | 统计与数据科学论坛

1 Like

This is asking you to update the rlang package


If you get an error message while doing this, please post it here to give you further advice.

1 Like

Thanks a lot. I did update the rlang package and it worked.

Thanks for the reply. As andresrcs said I update rlang and it worked.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.