Deploying Error, No problem a few days ago

this is my app, and I want to change it so
after some change and I tried to publish, but I couldn't,

I updated Rstudio and R, but they do not work.

before publishing it works very well in PC.
for other apps even with no change, I couldn't publish

============== this is error message =================
WARNING: '-e { options(repos = c(CRAN = '', CRANextra = ''), download.file.method = 'wininet'); rsconnect::deployApp(appDir = 'C:/Users/user/Dropbox/shiny app',appFileManifest = 'C:/Users/user/AppData/Local/Temp/9190-3751-2d8f-fb6b', appPrimaryDoc = 'streamgraph.R', account = 'jee-hyoung-kim-19',server = '', appName = 'streamgraph', appId = 287476, launch.browser = function (url) { message('Deployment completed: ', url) }, lint = FALSE,metadata = list( asMultiple = FALSE, asStatic = FALSE, ignoredFiles = ' (DESKTOP-4MEAEH9's conflicted copy 2017-12-01).Rhistory| (DESKTOP-4MEAEH9's conflicted copy 2017-12-22).RData| (DESKTOP-4MEAEH9's conflicted copy 2017-12-22).Rhistory| (DESKTOP-4MEAEH9's conflicted copy 2017-12-28).RData| (DESKTOP-4MEAEH9's conflicted copy 2017-12-28).Rhistory| (DESKTOP-4MEAEH9's conflicted copy 2018-01-19).RData| (DESKTOP-4MEAEH9's conflicted copy 2018-01-19).Rhistory| (DESKTOP-4MEAEH9's conflicted copy

I think I found the reason or solution!
I do another computer with new working folder, new Rhistory.....
It works!!
it is not the server problem!

I leave this post for others with same problem.

Do you have a diff for what you changed (either with Git or some other version control system)? If you could include the code used that would be helpful.

Even if you can't produce a fully self-contained reprex (short for minimal reproducible example), tt will help us help you if we can be sure we're all working with/looking at the same stuff.

Right now the best way to install reprex is:

# install.packages("devtools")

If you've never heard of a reprex before, you might want to start by reading the help page. The reprex dos and don'ts are also useful.

For pointers specific to the community site, check out the reprex FAQ, linked to below.

I don't think this is a coding error, but there is something error in server = ''.
because exact same code(other app) cannot be republished any more.
(for experiments I tried)

error messsage is different from usual.

I cannot post the error messsage because not allowed (more than 2 links)

You should be able to post the full error message now (let me know if you can't), if you could try that could be helpful.

The code and/or diff would still be helpful in diagnosing the issue.

1 Like

Thank you for your treat,
I editted the original post,

I think I found the reason!
I do another computer with new working folder, new Rhistory.....
It works!!
it is not the server problem!