Dependency not installing during R-CMD-check

Hi. I am attempting to run R-CMD-check via a github action but it fails on the windows release. Everything passes on my local machine, but on github it attempts to install the 'RRPP' package but fails as it can't find the dependency 'pillar'. After failing to install 'RRPP' it then installs 'pillar' successfully. It seems like it is doing it in the wrong order, but I don't see how I can control this with the workflow script.
It all worked fine up until my most recent package updates that were only minor, such as including a new vignette, and should not have changed anything in the dependencies or imports.
My package is here,, and the RRPP package is a dependency of the 'geomorph' package that is used in my package.
Any help would be greatly appreciated.

What could work is switching to a newer workflow using pak (your current workflow uses the remotes package) e.g.

  • It might just work!
  • The log will be nicer to use in any case.

Thanks very much for the advice. I tried using the workflow you suggested but instead of just the windows check failing, each OS failed and each for a different reason. I tried my original workflow again without changing anything, and now it is running fine. Scratching my head about why this would be but I don't understand enough about how the R-CMD-check works to diagnose these issues, or why the check would pass on my local machine but not in github. Thanks again anyway.

1 Like

This topic was automatically closed after 45 days. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.