Dependency is not satisfiable: libc6 (>= 2.7)

Hi, I am trying to install Shiny Server on Ubuntu following the instructions Shiny Server - Posit. In the last step, after I run the command sudo gdebi shiny-server-, I got the following error.
Dependency is not satisfiable: libc6 (>= 2.7).
Does anyone know how to solve this?

hello @Binbin_Zhao,

sorry ot hear about your trouble. I cannot reproduce your issue with Ubuntu Bionic (18.04 LTS), Ubuntu Focal (20.04 LTS) and Ubuntu Jammy (22.04 LTS).

Can you please help understand me which Ubuntu version you are using ?

Many thanks,


PS: I have built a Dockerfile that contains all the necessary steps for successfully installing shiny server on the mentioned Ubuntu distributions. Copying it here for reference (you can specify the Ubuntu version via the --build-arg argument (e.g. --build-arg DIST=jammy)

ARG DIST="focal"

FROM ubuntu:${DIST}

ENV DEBIAN_FRONTEND=noninteractive

RUN apt-get update && apt-get install -y software-properties-common wget ca-certificates && \
    wget -qO- | \
        tee -a /etc/apt/trusted.gpg.d/cran_ubuntu_key.asc && \
    add-apt-repository "deb $(lsb_release -cs)-cran40/"

RUN apt-get update && \
    apt-get install -y --no-install-recommends make \
                            g++ \
                            r-base=4.3.2-1.`echo $(lsb_release -rs) | sed 's/\.//'`.0
RUN R -e "install.packages('pak', repos = sprintf('',.Platform\$pkgType,R.Version()\$os,R.Version()\$arch))"

RUN if [ ${DIST}=="bionic" ]; then apt-get install zlib1g-dev -y; fi

RUN R -e "dist<-system('lsb_release -cs',intern=TRUE); options(repos=sprintf('',dist));options()\$repos;pak::pkg_install('shiny@1.8.0')"

Hi, @michaelmayer ,
Thanks for your reply and help.
The version is Ubuntu 22.04.3 LTS (GNU/Linux 6.2.0-1017-aws aarch64) and it is a AWS server.
I am not quite familiar with Docker, when I try to build with the command
sudo docker build --build-arg UBUNTU_VERSION=22.04.3 -t human_mice_gene:tag .
I got the following error

3.665 The following packages have unmet dependencies:

3.853  r-base : Depends: r-base-core (>= 4.3.2-1.2004.0) but it is not going to be installed
3.853           Depends: r-recommended (= 4.3.2-1.2004.0) but it is not going to be installed
3.876 E: Unable to correct problems, you have held broken packages.
  11 |     
  12 | >>> RUN apt-get update && \
  13 | >>>     apt-get install -y --no-install-recommends make \
  14 | >>>                             g++ \
  15 | >>>                             r-base=4.3.2-1.`echo $(lsb_release -rs) | sed 's/\.//'`.0
  16 |     RUN R -e "install.packages('pak', repos = sprintf('',.Platform\$pkgType,R.Version()\$os,R.Version()\$arch))"
ERROR: failed to solve: process "/bin/sh -c apt-get update &&     apt-get install -y --no-install-recommends make                             g++                             r-base=4.3.2-1.`echo $(lsb_release -rs) | sed 's/\\.//'`.0" did not complete successfully: exit code: 100

This is very helpful feedback and now your Dependency is not satisfiable error makes sense - you are using Ubuntu Linux 22.04 LTS (code-named "Jammy") which is great - the problem though is that you are using aarch64 architecture which means you have some ARM CPUs. Shiny Server however is built for the x86_64 architecture which is incompatible with aarch64.

I will see if I can find out if there are any plans to release an ARM build for shiny server but for the time being I would suggest you to use a different, x86_64 compatible instance for your Shiny Server setup. Any instance type that does not have the g at the end of its name (g for AWS Graviton) will work.

Thanks so much, Michael, very helpful.

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.