cygwin error after installing rtools40 - conflict with git bash ?

Preface: I have successfully been using rtools for some years.

I followed the instructions to install rtools40, but get the following error message when trying to use the terminal (to do anything) in rstudio:

0 [main] cut (8896) C:\rtools40\usr\bin\cut.exe: *** fatal error - cygheap base mismatch detected - 0x180331408/0x180316408.
This problem is probably due to using incompatible versions of the cygwin DLL.
Search for cygwin1.dll using the Windows Start->Find/Search facility
and delete all but the most recent version. The most recent version should
reside in x:\cygwin\bin, where 'x' is the drive on which you have
installed the cygwin distribution. Rebooting is also suggested if you
are unable to find another cygwin DLL.

  1. i can't find cygwin.dll anywhere on my computer, let alone 2 versions
  2. I tried reinstalling rtools40 as admin, didn't resolve
  3. I tried installing Cygwin manually, just in case, even though i have not had to do that before, ironically i still can't even find that .dll

This SO post implies that it may be a conflict in that the terminal in R studio is a git bash window...

So i changed the terminal to a simple command prompt and i can run commands like ls and which, but i can't execute a bash script.. which is the whole reason i got to this point to begin with. I want to use a git bash terminal window.

i can't imagine Rtools messing with git bash this bad, but i can't figure out where i went wrong in updating R, R studio & R tools.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.