Cursor offset, black bar across top of RStudio

I recently updated RStudio to 1.2.1335 when I realized I'd been still running a 1.1.463 version for a while. When I first launched, I noticed this black bar running across the top of window.

I quickly noticed that the cursor is clicking lower than it is showing up. I don't have the cursor in the screen grab but for an example, I can position my cursor in such a way that I have the "I" type shape cursor that perfectly aligns with the "L" in "Tools" on the top navigation bar (instead of the arrow), and clicking allows me to type in the "Go to file/function" field, rather than opening the Tools menu. I have to move almost into that black bar in order to open the Tools menu.

I tried refershing the UI and adjusting the zoom and neither helped. Interestingly, adjusting the zoom worked as expected for everything except the navigation bar which stayed the size you see here.

I uninstalled RStudio and re-downloaded 1.1.463 and upon installing that, I didn't see the issue. When I re-downloaded and re-installed 1.2.1335, the issue had returned so it seems to be a problem with the latest version on my machine (running Windows 10 by the way). Happy to provide any other relevant information as necessary. Any ideas?

1 Like

RStudio v1.2 does unfortunately have some rendering issues with certain system configurations. This article may be helpful:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.