Creating Package. How do I access 00install.out file?

Please bear with me as I am trying to create my first package

When I run Build>Check package i.e

devtools::check(document = FALSE)

I get this error

* checking whether package 'epldata' can be installed ... ERROR
Installation failed.
See 'C:/Users/agcur/Documents/R/epldata.Rcheck/00install.out' for details.
Status: 1 ERROR

but cannot seem to locate this in my files



In Global Options, I have the "View Rcheck directory after failed R CMD check" checked

But the R cmd check was successful. It just had an error

In the Project Options>Build Tools I have a blank entry for "Check Package - R CMD check additional options

Are you definitely looking inside the foo.Rcheck directory in the parent directory of package foo?

There have definitely been changes in the past few months in the packages that constitute devtools and their behaviour around this specific thing. So making sure all of that is very current, possibly even at a dev version, is also a reasonable thing to try.

I'm definitely not! I cannot find a directory named that anywhere

The build >check package is still producing the error, but if I run Build>install and restart it seems to work and I have the package available locally and documentation is correct

Yeah I was seeing behaviour like this a few months ago but it has since been resolved.

What version of devtools do you have?

1.13.5 (blah blah to get to 20 characters)

I'm running the dev version of devtools and this has been fixed in it. If you're willing, try installing devtools from GitHub.

1 Like

I've been installing it for the last 5 minutes

@jennybryan That seemed to get rid of error message. Thanks for help