Creating new project in Posit Cloud from private GitHub repository

I am trying to open a new project in Posit Cloud from a private GitHub repository. I did the following:

  • In Posit Cloud Workspace, selected "New Project" and "New Project from Git Repository" following this guide

  • Went into my authentication settings in Posit Cloud and connected my GitHub account

However, I receive this error: "Cannot access git repository" "We are unable to access a repository at that URL - make sure you entered the URL correctly and that the repository is accessible to your currently linked GitHub account."

From this thread it looks like I need to edit the third party access settings on GitHub. However, I cannot figure out where or how to edit these settings. Where and how do I change these settings within GitHub?

There appears to be an open issue, associated with the domain name change.

Hello, yes. The repo is accessible from my Posit Cloud linked GitHub account

Sorry to be obscure. I think github expects the remote client to still be in the domain when it is now coming over as the domain.

Hi! Please see this comment for more details on this error and how to fix it. Create RStudio Project from Organisation Private Git Repo - #3 by Robby

If the solution above doesn't solve your problem, please let me know so we can investigate further.

Hello, thank you. I tried the solution (unchecking "Private repo access also enabled," then waiting a bit and then re-checking it again). I did receive any prompts when I re-clicked it and did not solve the problem (I still get the same error when trying to create a project from the private repo).

It sounds like you're having a different issue. Are you attempting to access a private repo that exists within a GitHub org that you are a member of?

Hello, I am trying to clone a private repo that was created by a colleague. I am listed as a collaborator in the repo. Does that answer your question?

Not really, but if the repo in question is part of an organization, you might need the owner of that organization to enable 3rd party access:

Hello, thank you. The owner followed the instructions you sent, but I am still getting the same error message.

In case this info is helpful, my GitHub is set up with an email account belonging to the same organization as the email account that the owner has associated with their GitHub account

Is there something else I can try?

I tried going into the terminal of another, already existing project in Posit Cloud to set my global GitHub credentials, but that did not change anything either

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.