Could not resolve host when trying to install package from GitHub Enterprise account

When I try to install a package from a GitHub enterprise account I encounter the following error message.

devtools::install_github(repo="jpowers4/d4ds", host = "")

Using github PAT from envvar GITHUB_PAT
Error: Failed to install 'd4ds' from GitHub:
Could not resolve host:

I'm not sure where to go next for trouble shooting. All spelling is correct and this function has worked at all other enterprise GitHub accounts that I have used. I am otherwise able to use this GitHub account from RStudio without issue.

Are you sure about the url to join the api endpoint of your hosted github ?
This error usually mean that the url can't be reached (no internet or does not exist).

For GHE host, I usually see some of the form This is the form used in help page too

Have you tried this api endpoint ? /api/v3 ?


"/api/v3" was the missing ingredient

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.