Corrupted Project in Rstudio Cloud?

I'm teaching a class using RStudio Cloud for the first time this semester. Last week, on Wednesday, I had all the students create Cloud accounts, then a new Project. We installed a couple of packages, wrote a very short R script, and that's all. On Friday, I tried to have the students write another short R script within the project that they had created, however 3 out of the 49 students could not open the Project.

I sat down with one of those students today and it seems that her project is corrupted - it will not load properly - the icon just spins (we let it run for an hour). She was able to create another new Project fine, but then she had to install the packages and the scripts that were in the original file are not available to her. No big loss since we haven't done anything useful yet, but I'm concerned that this might become a bigger issue later in the semester. She was using Chrome browser - I even tried clearing her cookies and cache to no avail.

Any thoughts or suggestions? Why would a project fail to open?