Connection to Access-database not showing in RStudio


I have two different computers, both with R and RStudio installed.
If I run RStudio (2021.09.1/Build 372) with R 64bit (4.1.29 on Computer A, I can see and connect to the 32bit MS Access database connections.
If I run RStudio, I only see the 32 bit MS Access database connections when I run RStudio with R 32bit (RStudio Version 1.4.1106, R 4.0.4; I can't update these due to firm restrictions).

Any idea why this might be the case?

The 64-bit version of R can't work with a 32-bit database driver, the architectures have to match, so you need a 32-bit version of R too. This is not related to the RStudio IDE.

So why does it work on my Computer A with R 64bit? And why are the 32bit connections showing up in RStudio and not on computer B?

Maybe because you also have a 64-bit odbc driver installed on that computer, I might be wrong but I think the odbc driver architecture is independent from the database engine architecture (i.e. MS Access). At least that is the case when working with RDBMS.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.