Connecting to SQL database in RStudio Server - SQLAllocHandle error

My organisation is trying out RStudio-Server (open version) on a Debian server. I need to connect to an Ingres database and have been using a vnode - I have tried to do this on the server using the DBI and odbc packages, but when I enter my connection details I get the following error:

    con <- DBI::dbConnect(odbc::odbc(), 
                      driver = "{Ingres II}",
                      server = "my_vnode",
                      database = "my_database")

    # Error: nanodbc/nanodbc.cpp:1021: 00000: [unixODBC][Driver Manager]Driver's SQLAllocHandle on SQL_HANDLE_HENV failed

The exact same code works fine if I run it using command-line R on the same server. I also have the same vnode setup in RStudio desktop and the same code works there. Is there any way I can address the above error, or alternatively is there another means of connecting to a database in RStudio Server?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.