Cloudml package `Error in gsutil_binary() : failed to find 'gsutil' binary`

I'm getting the following error when I try to submit a training job to Cloud ML using the cloudml package (I'm replicating the keras fraud example here):

Error in gsutil_binary() : failed to find 'gsutil' binary

I've used gcloud_install() and installed everything, and set up my configurations with the shell as it opens after install. Running gsutil --version gives me gsutil version: 4.28, so it seems to have installed OK.

Anything I'm missing?

Same issue here. Using Windows 10, RStudio 1.0.136 and R version 3.3.2. Gsutil seems to have installed OK just as the OP said.

Can you please tell me about your python installation?

Specifically, do you use Anaconda?

Hi @_andrie, I don't use Anaconda. My Python info is:

$ python --version
Python 3.6.3

This issue has now been fixed. See the issue tracker at

If you pull from the github master branch now, it should work. (If you still experience problems, please report here or file a new issue at

1 Like

Great, solved now, thanks @andrie. I still needed an explicit job_collect() command (the Y didn't work when I was given the choice in the R console), but otherwise worked great.