"Click to view" option dissappears from global environment after changing dataype of column in data.frame

Hi dear R-Studio Community,

I have noticed the following odditiy recently: When I am changing the data type of columns in my data.frame the "click to view" option dissappears from the data.frame in the global enviroment, along with the icon next to the data.frame and the byte information. This however apparently only happens with data.frames of a certain length.

Note: I work within a R-Project and the data.frames are created based on a .csv I read in.
Note: I am using the following version, both having recently upgraded the Studio and R version itself.

platform x86_64-w64-mingw32
arch x86_64
os mingw32
system x86_64, mingw32
major 3
minor 6.0
year 2019
month 04
day 26
svn rev 76424
language R
version.string R version 3.6.0 (2019-04-26)
nickname Planting of a Tree

I have created the following example data to demonstrate only how it looks like to me, not how it is produced:

ID_1 <- as.character(seq(1:20))
Trial_1 <- rbinom(ID_1, 1, 0.5)
Data_1 <- data.frame(ID_1, Trial_1)

ID_2 <- as.character(seq(1:100))
Trial_2 <- rbinom(ID_2, 1, 0.5)
Data_2 <- data.frame(ID_2, Trial_2)

Data_2 has no option for click to view on my side and appears as described above.

If you would like to repoduce it for yourself, this code addition basically produces the odditiy I described.

write.csv(Data_1, "Data_1.csv", row.names = FALSE)
write.csv(Data_2, "Data_2.csv", row.names = FALSE)

Data_1_fromCSV <- read.csv("Data_1.csv", header = TRUE)
Data_2_fromCSV <- read.csv("Data_2.csv", header = TRUE)

Data_1_fromCSV$Trial <- as.factor(Data_1_fromCSV$Trial)
Data_2_fromCSV$Trial <- as.factor(Data_2_fromCSV$Trial)

This is certainly not a dramatic thing, but still unpleasant to look and work with for me. Any help is appreciated!

Thannk you very much,

This sounds like a bug that may be fixed in the preview release -- would you be able to check and see if the issue reproduces for you there?

1 Like

Hi Kevin,

Thanks! I have tried the new release and the "click to view" option works, the icon and byte information, along with the option to get a structure overview by clicking the icon is not working.

Edit: I went to my old version and "click to view" also works now, I am therefore unsure if I miss stated its original functioning. The other bugs, i.e. missing icon and clickable icon, were correctly stated.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.