Circularity after update to RStudio-2022.12.0-353 - keeps re-installing instead of starting

Apology first: Trying to ask relevant question BUT am 70+ and still learning.
Problem: Recently downloaded RStudio-2022.12.0-353. Cannot open it. All attempts lead to re-installation window.
History: Downloaded new version on advice that my previous version (successfully used) was outdated.
Possibly related problems: Tried to have shortcut icon placed on Desktop. However, click on desktop icon leads back to installation option.
Further apology: Tried to find related questions before sending this but have not yet found a workable match.
Sincerely grateful for help.

You’re in luck. I’m 75. No apologies needed.

What is you OS? Have you installed the separate R application?

Thank you. my OS is Windows 10. Yes, I have installed R 4.2.2 and have been using it (relatively) successfully with the previous version of RStudio.
I may have replied into the Ether earlier, as I can't see any evidence of it showing up in the post, so here is a cut and paste which I hope does not add redundant reading time:

Possibly relevant background:
I have used RStudio to run R a fair bit in the past, but often with 6 months gap (so I forget things). I am 73 (so not 75 but maybe more weathered).
Also not an IT wiz. Don't seem to be able to learn the modern terms. (I admit to be a retired economist with some ancient econometrics background).

Elaboration of problem (may not be relevant):
I previously had an icon on my desktop that opened RStudio with a single click and immediately opened my latest file of code that worked in R.
The new installation gave me an option to put a shortcut somewhere, so I opted for the desktop. But when I click on the new icon I just get the option to re-install RStudio instead of opening a working version of it.
Also my old icon no longer works - it seems the new installation has disabled the old version.
I can still use R 4.2.2 as a stand-alone, but have so little knowledge of the command window environment that I don't want to do that. I had lots of working code in files associated with the old version of RStudio, although I am still not a wiz at that - it's pretty primitive code.

Not sure exactly what I should send you that might help diagnostically.

Thanks to 'Technocrat' and apologies for the post. I think I have found a work-around for my problem. Although I don't have a working start-up icon I have found I can click on an old file of code and it takes my right into the new version of RStudio, which obviously has been installed even though I can access it in the way I expected. I should have realised this. It comes from several months away from the task. No need to consider this further, but thanks for considering my problem.

Glad that's working. I began to suspect that the shortcut was for the installer, rather than the program itself, but since I haven't used Windows since Alan Greenspan was only half-way through his term, I was trying to figure out how to confirm.

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.