cd ~ command in Rstudio

I am new to RStudio and Unix. I am trying the Unix commands using Rstudio Terminal. Whenever I try "cd ~" command, I am getting the message "The system cannot find the path specified". However, all other commands that I have tried are working. Can someone help with an answer,

Hi Srinivas, welcome!

RStudio terminal pane it is just a system terminal so you should be able to access your home directory with that command, are you able to do it on a regular system terminal (not in RStudio)? If you can't, then most likely your problem is not related to RStudio and maybe you should ask this on a more appropriate forum for your particular OS.

Hi Andre,
Thanks for reverting. Earlier any command starting with "~" was not working for me either in RStudio or using Gitbash. I have unchecked and rechecked the "attributes" box in the "properties" for "documents" folder which is an intermediary between the "user (my name)" and my RStudio project directory (folder). After doing so, "~" command is working in both RStudio and Gitbash. However, my home directory is showing as my user directory (username@computerrname). Besides, at the end of each command line after I execute "cd" command, I get the string "(master)" for sub directories below "documents" folder. I am not sure what does this "master" string mean....

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.