Cant upload my Shinyf7 app :(

I built an app based on the wonderful shinyf7 template, but I cant upload it online. Any ideas?

You already have upload it, but the app won't start, that is different, check the logs for your app so we can see what is going on.

1 Like

Well, the same message on the screen appears in the logs.

Ok, just notice that we prefer formatted text instead of screenshots, it makes things easier for helpers

It seems like shinyF7 package is not being loaded, try reinstalling the package from github in your system with devtools::install_github("RinteRface/shinyF7"), make sure you are loading the package in your app with library(shinyF7) and redeploy your app to


Well, it kind of worked - but when I tried to add a map from the leaflet package I got a very similar message:

An error has occurred

The application failed to start (exited with code 1).

Error in value[[3L]](cond) : could not find function "leafletOutput" Calls: local ... tryCatch -> tryCatchList -> tryCatchOne -> <Anonymous> Execution halted

This is a different problem, but probably with the same cause, make sure you are loading the leaflet package in the code for your app with library(leaflet)

To deploy to you need to have the package installed, and you need to load it in your script using library. This way, when publishing, the process can find the dependencies and asked for them on the deployment server. If you don't put library(leaflet) somewhere, it can't guess that leafletOutput requires leaflet package and your app won't work on the server.

You can test locally by opening a new clean session and run your app. If there is no error, it should work, providing you send the same files on the server.

hope it helps understand the why.

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.