can't store data at section "Applications", variable "DisabledProtocols"

Hi all,

Can someone please help me,
I'm trying to block SockJs on the rstudioConnect configuration by following the instruction on the official documentation but it still doesn't work,
attached the captures on the format and the error in the log.
Thanks a lot for your help.

Best regards,
Andrianaja Ranaivoarivelo

and this is contained in the RstudioConnect configuration file.

Best regards,
Andrianaja Ranaivoarivelo

Howdy @manarivo !

This setting was changed to a Multi Value setting in the 1.8.0 release (long ago :smile: ), as discussed here:

You should be able to resolve by changing to:

DisabledProtocol = websocket
DisabledProtocol = xhr-streaming
DisabledProtocol = iframe-eventsource
DisabledProtocol = iframe-htmlfile
DisabledProtocol = xhr-polling
DisabledProtocol = iframe-xhr-polling
DisabledProtocol = jsonp-polling

Do you have a link to the documentation that you're using for this setting? We may have missed updating something!

I'm also curious why you're disabling all of these protocols? Do you mind explaining a bit more about why you are disabling all of these?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.