Can't publish to RPubs or Posit Cloud

Env: RStudio 2023.12.0, R 4.3.2

I have an R script I knitted and want to publish to Rpubs. I click on the publish icon, then select Rpubs, but nothing happens when I click 'Publish'

I also tried to publish to Posit Cloud. I created credentials, named `MyPositCloud'. Then tried to setup authentication via

> rsconnect::setAccountInfo("MyPositCloud", token = "*****************B5E1A9A", secret = "**************8fjyV7Or0E", server = "")
Error in `GET()`:
! <> failed with HTTP status 401
invalid token
Run `rlang::last_trace()` to see where the error occurred.

Why doesn't Rpubs work? Is there a command line alternative?
What is wrong with how I'm trying to authenticate to Posit Cloud?

I also tried using rpubsUpload() directly and get an error:

rsconnect::rpubsUpload("Coefficient plots for linear models", "examples/coefplots-demo.html", originalDoc = "examples/coefplots-demo.R")
[1] "<html>\r\n<head><title>502 Bad Gateway</title></head>\r\n<body>\r\n<center><h1>502 Bad Gateway</h1></center>\r\n</body>\r\n</html>\r\n"

I re booted and retried rpubsUpload() today. This worked.

However, it still doesn't work from the Publish button: Nothing happens.

As well, I still get the same error when I try to setup authentication to Posit Cloud with rsconnect::setAccountInfo()

What is the problem & how can I fix it?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.