Can't open R studio IDE

i uninstalled R studio in ubuntu and cleared all the existing files using commands like sudo apt-get remove r-base sudo apt-get remove r-base-core and sudo apt purge r-*.

when i tried to re install using IDE, it installed but when i am trying to open the IDE it is not at all opening and showing the error "Path to R not specified, and no module binary specified; Invalid R module ()".

please help


Have you reinstalled R after uninstalling it? RStudio is an IDE for the R programming language but it doesn't come with R bundled, you have to install it separately.

1 Like

Thank you for your help.

yes i re installed R IDE only but not language. i thought R IDE can itself work.

i am very new to R language, please guide me

i just want to you update that i tried to install r-base. But unfortunately another error happens. there is an error showing..

The following packages have unmet dependencies:
r-base : Depends: r-base-core (>= 4.1.2-1.2004.0) but it is not going to be installed
Depends: r-recommended (= 4.1.2-1.2004.0) but it is not going to be installed
Recommends: r-base-html but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

i have tried so many ways that i found in online but didnot work. please help

Here you can find the official instructions for installing R on Ubuntu

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.