Can't make new rmarkdown file

Hello, I really have a bit strange problem when I want to create new Rmarkdown file. Because usually I can create new Rmarkdown file just fine without any problems but now I can't even create one Rmarkdown file. This is the error message that occur if I want to make Rmarkdown file
rmarkdown error message

Really need help with this problem.

The error message is asking you to update those packages. Have you tried doing so? Do you get any error message if you try to update them?

I already try to update all of those package in this update icon like usual !
But when i search all package that required to be update, it said that all package are already up to date like this

It's really confused me a lot

That is weird, I would need more information to help you out, let's try addressing a package at a time so we can get more detail about the issue, Can you try installing the first package with this command and posting the complete output message you get?

install.packages('evaluate', repos='')

Finally it work, i can make new Rmarkdown file again. But I wonder what is the difference when you want to update package with that command and search manually in update button.
And I hope the message that appear when i run those install.packages command was normal

Possibly the difference is the package repository you have set as default, and another probable source of issues is the fact that you have set your default package library in a cloud synced folder (OneDrive) and R has problems with this very often.

Is there a way to check my package library location. Really want to know if this kind of problem happen again

You can change the default library folder by setting your R_LIBS_SITE environmental variable on a .Reviron or .Rprofile file

# In a .Renviron file you can set it by adding this line
R_LIBS_SITE="C:\\Program Files\\R\\R-4.0.5\\library"

For a more detailed explanation, you can read this blog post

Btw I think I already got a real culprit why Ican't make rmarkdown file. I think that's because of the sql server that i download contain the minor r program app I think. So the package location are changing at rstudios. But I really need the confirmation since maybe this is coincidence too since one of my friend got the similiar accident after download sql server

It is not clear what you mean with this but it seems very unlikely that your sql server configuration would have any effect on RStudio.

So right now I have download this SQL Server with SQL Server Management Studio for my university courses.
And in the SQL Server itself there are R studio feature like this
I forgot to screenshot the whole installed feature. But there's definitely R studio feature in there. So I might think the R feature in this SQL Server might be the culprit of this problem. But I really want to confirm if this is true since my friend also have the similiar issues after download the SQL Server and SQL Server Management Studio.

I hope that my question are pretty clear. And sorry if my english are really bad. ot my mother language t be honest.

I'm pretty sure those are not RStudio features but integrations with the R programming language and as I said, it's very unlikely that they will affect RStudio's configurations.

The most probable causes of your previous problem are a bad CRAN repository and using an incompatible file path for your package library, so I think you are just chasing ghosts with your sql configuration.

Ooo okay. Thanks again

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.