Can't login in RStudio Server and pamtester no longer provided in RStudio Server?

I am having some issues with setting up RStudio Server. I can get to the login page, but when I try to login with the user that I defined, it states that the login is incorrect...

I tried to follow the manual which suggests trying to run the "pamtester" app, but that does no longer seem to be bundled (/usr/lib/rstudio-server/bin/pamtester is not there).

I tried to install from the original sourceforge page but I was running into compile issues and not sure how to fix those...

My instance is running on a docker instance that is mostly running on a read only image, but I redirected all the location that RStudio needs to write in to the writeable portion, but still no joy...

I also have an issue in trying to change the password for the user when I try to run "paswd" on the docker image...It gives "passwd: Authentication token manipulation error" when I run it on a system that is read-only (obviously, since /etc/shadow is read only) but it does not even get passed the entry of the current password, so I am guessing that password testing on a read-only system does not work?

Confused in California,


1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.