Can't install Tidyverse (need ggplot2) in latest version of Rstudio (2023.03.1 Build 446)

Trying to get install ggplot2 and thought it would be a simple matter.
If i try install.packages("tidyverse") or install.packages("ggplot2") the installation ends in non-zero exit status.

Part of error is:

Error i loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
namespace 'rlang' 1.0.2 is being loaded, but >= 1.0.6 is required

so I tried remove.packages("rlang") followed by install.packages("rlang") as per a similar problem I found on this forum, but it just installs v1.0.2 again and the non-zero exit error continues.
I also tried install.packages("", repo=NULL, type="source") from source, but it fails with 'make' not found

I read elsewhere that rlang_1.0.6 isn't compatible with the latest version of Rstudio?
Does this mean I can't use tidyverse/ggplot2 with the latest Rstudio?

I tried looking in to installing an earlier version, but which?
I really need to be able plot for my thesis work and the only experience I have with plotting is in ggplot.

Please help.

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.