Can't install devtools - non-zero exit status

Hey everyone,

I really need urgent help. My perfectly working RStudio suddenly stopped working entirely for not clear reason. I've tried uninstalling and reinstalling all the packages, but that just seemed to make the problem worse. Now I can't install almost any package without getting the non-zero exit status problem.

When I try to install devtools, for example, I get the below.

I've also tried dependencies = TRUE with similar errors.

Anything else? I don't understand why uninstalling and reinstalling the software doesn't fix the problem but I'm getting a bit desperate here.

also installing the dependency ‘rcmdcheck’There are binary versions available but the source versions are later:
binary source needs_compilation
rcmdcheck 1.3.2 1.3.3 FALSE
devtools 1.13.6 2.0.2 FALSE

installing the source packages ‘rcmdcheck’, ‘devtools’
trying URL ''
Content type 'application/x-gzip' length 45380 bytes (44 KB)

downloaded 44 KB

trying URL ''
Content type 'application/x-gzip' length 388141 bytes (379 KB)

downloaded 379 KB

  • installing source package ‘rcmdcheck’ ...
    ** package ‘rcmdcheck’ successfully unpacked and MD5 sums checked
    ** R
    ** preparing package for lazy loading
    Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) :
    there is no package called ‘processx’
    ERROR: lazy loading failed for package ‘rcmdcheck’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.4/Resources/library/rcmdcheck’
    Warning in install.packages :
    installation of package ‘rcmdcheck’ had non-zero exit status
    ERROR: dependency ‘rcmdcheck’ is not available for package ‘devtools’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.4/Resources/library/devtools’
    Warning in install.packages :
    installation of package ‘devtools’ had non-zero exit status

Have you tried installing this missing dependency?

1 Like

No, strangely it just began to work again.

I think it might have been a combination of all the advice I tried here. Installing/re-installing Xtools, updating my operating system, re-installing RStudio, reinstalling R etc...

I wish I could say what exactly fixed the issue, but it wasn't working and then suddenly began working.

Thanks for the help anyway though.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.