Can't get server to start - R discovery error

I'm trying to run rstudio-server on our cluster but I can't get it to start. There's some problem with the discovery of the R version which is causing the launch to fail

$ /usr/lib/rstudio-server/bin/rsession --standalone=1 --program-mode=server
Listener bound to address port 8787
08 Jul 2020 11:27:35 [rsession-andrewss] ERROR system error 2 (No such file or directory) [path: ]; OCCURRED AT rstudio::core::Error rstudio::r::session::discoverR(rstudio::r::session::RLocations*) src/cpp/r/session/RDiscovery.cpp:62; LOGGED FROM: int main(int, char* const*) src/cpp/session/SessionMain.cpp:2122

I'm using a custom compiled R which is in the path.

$ which R
$ R --version
R version 3.6.1 (2019-07-05) -- "Action of the Toes"

I've tried setting RSTUDIO_WHICH_R in case that was the issue, but that didn't make any difference

export RSTUDIO_WHICH_R=/bi/apps/R/3.6.1/bin/R

I also tried setting the R version in a config file but the setting doesn't seem to be recognised.

$ /usr/lib/rstudio-server/bin/rsession --config-file=rsession.conf --standalone=1 --program-mode=server --log-stderr=1 --session-timeout-minutes=0 --launcher-token /tmp/rstudio-server-andrewss/secure-cookie-key --user-identity=andrewss --www-port=8080
Error reading rsession.conf: unrecognised option 'rsession-ld-library-path'

Since this is a cluster I don't have the option of putting R into /usr/bin/ or /usr/local/bin/ so any ideas of how to ammend the configuration to get this going would be appreciated.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.