Can't get RStudio to open Bad Image error

Whenever I click on the RStudio icon an error pops up that says
rstudio.exe - Bad Image
C:\Program Files\RStudio\bin\Qt5PrintSupport.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0xc0000428.

I get the same error for Qt5Network.dll, Qt5Network.dll, Qt5Core.dll, and Qt5Gui.dll.

I am using the most up to date versions of RStudio and R as of today.

I am using windows 10.

I am new to the community so please let me know what further information is needed and/or proper way to post etc. This occurred yesterday after I updated RStudio and I tried to troubleshoot all day, but I can not figure it out.

Any help would be greatly appreciated.

Hi! Welcome! Sorry to hear you’re running into trouble. A couple of questions:

  • Have you tried uninstalling and reinstalling RStudio?
  • When you say you’re running the latest release, do you mean v1.1.456 or the current Preview release (v1.2.830-1) — or one of the dailies?

(I don’t know what is going wrong, but more debugging info will help others who might have a better idea)

Here’s a template for providing system information…

System Information:

  • RStudio Edition: (Desktop or Server)
  • RStudio Version:
  • OS Version:
  • R Version:


Depending on your issue, the following may be useful
If a section isn't relevant or you can't collect it just delete that section below

System Information:
RStudio Edition: Desktop
RStudio Version:v1.1.456
OS Version: 64bit Windows 10 Pro version 1803
R Version: 3.5.1

I can't not get to anything RStudio related.

I have tried to uninstall and reinstall quite a few times.

Thank you for responding!

Can you also provide a screenshot of what you're seeing, just so we know exactly what the error message looks like?

You might also try uninstalling + reinstalling RStudio after restarting your computer, in case that hasn't been attempted just yet.

I ended up finding that a lot of c++ .dll's were missing (not sure why). So, I wiped my computer and reloaded windows and it works now. I don't know what happed or why it happened. If it happens again I will post it here.

Thank you.

I rtied to install ver1.2.50001 and R-3.6.1-win, however the system prompt me bellow error whe installing...

That usually implies that RStudio is already open while you are attempting to install it. Try restarting your computer and re-installing RStudio once more.