Can't download Rcmdr-package on my Macbook 11.2.3


I am a total beginner on all things concerning R.

Still, I am trying to use R-commander on my Mac (11.2.3) for a research project. However, I cannot get it to work. Interestingly, my problem seems to have been adressed here, without it for that matter being satisfactorily resolved for what I understand (I found at least one more thread dealing with sort of the same thing in this forum, but new users were not allowed to include two links in one post..)

Basically, I can't download R-commander. When I type "install.packages("Rcmdr")" I will get the following answer: "

Content type 'application/x-gzip' length 4452046 bytes (4.2 MB)

downloaded 4.2 MB

The downloaded binary packages are in

I have the latest XQuartz-update on my computer. Moreover, I have tried everything that I have been able to find in the few other threads dealing with this problem or problems adjacent to mine, but nothing seems to change for me – the program keeps repeating the stuff I quoted here above.

If anyone has any idea of what might be the problem here, I would be incredibly grateful to hear about it.



You are not showing any error message, it seems the package is successfully installed. Do you get any error message if you try to load it?


Hi, thank you for taking your time.

As for the commando you mentioned—I have tried that. I will then get the following thing written out to me:

"Loading required package: splines
Loading required package: RcmdrMisc
Loading required package: car
Loading required package: carData
Error: package or namespace load failed for ‘car’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
there is no package called ‘vctrs’
Error: package ‘car’ could not be loaded"

This means you are missing a package dependency, you have to install the vctrs package.


Yeah, but every package that I try to install generate the same kind of response, i.e., this message:

--- Please select a CRAN mirror for use in this session ---
trying URL ''
Content type 'application/x-gzip' length 1410136 bytes (1.3 MB)
downloaded 1.3 MB

The downloaded binary packages are in

That is to say, I instantaneously receive a link through which I can sort of download the packages to my computer in some sense, but the packages won't download to the program itself. When I worked with R on my previous computer, the packages would download in the program if you see what I mean. It would take some minutes during which I visually saw files downloading in R, then it would be done. Nothing of that kind now.

I don't understand what you mean, again, you are not showing any error message, just normal installation messages. As far as I can tell, you have correctly installed vctrs in your system, now try to load Rcmdr again and see if it works now.

You are not supposed to follow that link, it is just for informative purposes.

In the output you are showing, I see the same thing you describe, a binary installer is downloaded and it's done.

You're completely right, of course—now it worked. Sorry for my stupidity and thank you dearly for your help.

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.