Can't copy/paste from finder in newest version of R Studio (Mac)

I can no longer copy/paste filenames from Finder into R Studio. I'm not trying to copy full file paths, just the names of the files. If I copy/paste into a text editor (or any web browser) first, then it works, but not directly from finder to R studio.

I've tried using keyboard shortcuts (command c/v) as well as using the finder to copy/paste.

The problem started when I reset my Mac and redownloaded R studio. Thus, I'm not sure if the problem is with my mac's settings or with the new R studio update. I think the problem is with R Studio, because the only thing that works is to reinstall an earlier version of R studio (the one that worked is 2022.02.0). The problem is that I'm running into compatibility issues with packages and the current version of R, so I'd like to have the most recent R Studio available.

Is there a setting somewhere I'm missing or is this a bug? It's a workflow killer to have to use a text editor to copy paste from the finder. I've never had this problem before.

macOS Ventura 13.2.1
2.3 GHz Quad-Core Intel Core i7
R Studio Version 2023.06.1+524 (2023.06.1+524)
R version 4.3.1 (2023-06-16)

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.