Cannot see output when making site with blogdown

I'm currently facing an issue where my .Rmarkdown pages are being rendered fine, except I do not see any output being displayed at all. No plots, no tables, nothing. I think somehow, my fig.path has been messed up.

The output for the line knitr::opts_chunk$get('fig.path') is ## [1] "index_files/figure-html/"
How do I fix the problem and reset the fig.path to default? Currently, I see no output being displayed at all, only code chunks.

My repo is hosted here: if this helps.
Live website deploy:

I think this is because you are missing this in your config

      unsafe: true

If you add it, it should render ok.


If you look at your markdown source file, you'll see the resulting plot and table are included using HTML directly inside your markdown document.

Hugo will ignore raw HTML by default. This is something we could not change, but just strongly advice to set this option unsafe to TRUE for goldmark renderer.
This issue will not happen when you use Rmd file as they will be generated using Pandoc and not Goldmark.

We've recently added some check function to give all the advice we have for a website. If you install the dev version, you can run blogdown::check_site(). I think you are missing other configuration so it could be useful to you.


More on these check functions in here:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.