Cannot publish to rsconnect despite connection

I'm attempting to publish a Shiny app from RStudio Server Pro to RSConnect. This app has been published previously (twice) without problems. Now when I try to publish, I receive a notification that I do not have an account connected, but when I go through the process of connecting, I still get the same error. I've also tried reconnecting and disconnecting, and have gone through various iterations of the process, but I consistently get the same error message.

Hey @KirkDCO! So sorry for the delay in getting to your message here, and sorry for the trouble you are experiencing getting your account connected!

Would you mind opening a support ticket by emailing ? If you can share some details around the error messages you are receiving, that would be great!

If you can generate a bit more diagnostic information, that would help us diagnose as well! You can set this in your R console by executing:

options(rsconnect.http.verbose = TRUE)
options(rsconnect.http.trace.json = TRUE)

Then try connecting your account / publishing again! The more information you can provide upon opening a support ticket, the more quickly we can get you resolved here! Also, if you can include the link to this message when you open a ticket, that will help ensure we get some consistency in our messaging to you :slight_smile:

Thank you for the response.

In this case, I gave up and then tried again a day or two later. On that attempt it worked and did not give any errors. I don't know what the problem was, but it seemed to resolve itself.

1 Like