Cannot open either .R or .Rmd files through File menu in R Studio

I am using RStudio 1.2.1335 on macOs Mojanve 10.14.5.

R version 3.6.1 (2019-07-05)

I cannot open either a .R file or a .Rmd file using the File>Open File menu. I have tried creating a new .R file and opening it but it does not open. Using the menu I can import a file.

This happened after I did a number of updates to RStudio, R, and the operating system.

I notice that I can't open R directly at this point either--has to go through R Studio. Generally not a problem but I was going to check if I could open a file in base R.

To get at these files I have to open them in a text editor and copy and paste to an R studio window. I have tried also clicking on them using Finder and explicitly opening with R studio.


Is there a command for opening a new file?

Thank you

Should say that using the menu I cannot import a file.

I would guess you lost/damaged your R installation (which is distinct from RStudio). If possible I would try reinstalling just the R portion from . At the least that might give you a diagnostic during the attempt.

Thank you very much. I think I figured it out:

  1. The Rstudio not opening a file from the menu went away on its own after a MacOs upgrade.
  2. The R problem went away after I manually deleted an earlier version of R than the one I'm currently running.

Back in business.

1 Like

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.