Cannot Load tidyverse and related packages

I am having a problem that was mentioned before by Lomas on 2018-05-29. Since it is the exact same problem, I am reproducing the way it was posed before:

I installed the tidyverse package (install.packages("tidyverse")) but when I want to load it (library(tidyverse)) I get an error saying that some package is missing, a new one every time. I have tried installing those packages one by one but I am on the 5th one now and keep getting a new, similar error saying that a new package isn´t installed. So far: ‘plyr’, ‘psych’, ‘gtable’, ‘reshape2’, ‘scales’... in that order... I quit trying at this point thinking that there must be some kind of problem.

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
there is no package called ‘scales’

It is incredibly frustrating because R was working just fine, and then suddenly it failed to load tidyverse, ggplot2 and dplyr. I've updated all the packages. I've installed Rtools. These were all suggestions that were made. But nothing has worked. Any help?

This is strange. I am not sure if scales is a tidyverse package but psych definitely is not one. IIRC nor are "plyr" or "reshape2".

I have had the same problem but never with those packages. My last R installation required me to install 3 or 4 sub-components of "tidyverse but not them. Is there any chance that you haze a library(psych) or library(reshape2) command in an open file?


I'm having a similar problem. In particular it's complaining about "broom" but broom fails to update, and the failure gives no error feedback. Just for the hell of it I installed a package not related to the tidyverse (shiny) and it seems to have been successful.

I posted a lengthy request for help in a separate message, with copys of the feedback I'm getting.

I finally got tidyverse to load. It required tremendous patience and faith that if I persisted in installing the requested packages, there would be a last one. I must have installed more than 30 packages one after another. After each such installation, I tried to load tidyverse and received an error message with a demand to install yet another package. I was stymied when I got the request to install the jasonite package. Every CRAN repository that I tried told me that I was installing a version of jasonite that was not compatible with my version of R. Eventually, I got the correct link by googling jasonite. Anyway, there was a final final installation after which tidyverse loaded. So it was a happy ending. But it is worrisome that I might have to undergo this ordeal everytime there is a new version of R and I make the mistake of upgrading to it.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.