Cannot load "car" package on Latest Rstudio and R

As you can see in the attached screenshot, I need the "car" package so I install it through the command in the console which automatically selects the global CRAN repository.
then I load it but it prompts an error saying that the object "vI" (capital i) wasn't found. I tried downloading and installing manually "car" but nothing changed.
I'm using R version 3.6.3 and Rstudio version 1.2.5033 (Both latest versions).
I really need this package especially to load others and in general to work on my econometrics assignments.
Thanks in advance.

Hi, and welcome!

Please see the FAQ: What's a reproducible example (`reprex`) and how do I do one? Using a reprex, complete with representative data will attract quicker and more answers. Not required for this type of question, though. Also, if you have assignment related questions, please review the homework policy.

Near the top line of the output is a warning that RTools is needed for this installation. Download the version highlighted in green Please start a new post if you have troubles installing that one. I can't help you because I've been Windows for 25 years now.

I'm windows too, I don't understand your point... And what has reprex got to do with my problem? I didn't understand :face_with_monocle: :sweat_smile:

I solved the problem in the end but, searching on the internet, this is a recurrent problem and often people do not find an easy answer.
The most sensible explaination (in my opinion of NOT a software engineer) is this one: since i kept trying to install the car package and other auxiliary packages, somehow some directory got corrupt in the process. There was no way I could make the package work without unistalling completely R and R studio, and rebooting the system after EACH step and reinstalling everything.
So I did, and also I installed the packages with the command: install.packages("car", dependecies = FALSE) so that the program didn't get stuck trying to install 30 packages all at once. I think ultimately since car package needs carData package, that needs rio package, that needs haven that needs data.table and so on the process was to much for the software.
I wish some developer looked into it so that no more time is wasted on such issues. I don't think it is acceptable that such a necessary and widespread tool like Rstudio still suffers from such silly defects.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.