Cannot install RGtk2 for launching rattle

beginner here. I tried to initiate rattle but it returned this:

The RGtk2 package is not available but is required.
Please install the package using, for example:

then I tried to install RGtk2 and Rstudio returned this:
package ‘RGtk2’ is not available for this version of R

I also tried downloading RGtk2 from here:

but when I rattle() it returned this:
package ‘RGtk2’ was installed before R 4.0.0: please re-install it

Is rattle obsolete or did I miss anything? Thanks in advance!

has been lonely for a long time. There appear to be ways to get it to work under current versions of R4.x but it's OS dependent. Edit your question to indicate your configuration by cutting and pasting sessionInfo()

#> R version 4.1.0 (2021-05-18)
#> Platform: x86_64-pc-linux-gnu (64-bit)
#> Running under: Pop!_OS 21.10
#> Matrix products: default
#> BLAS:   /usr/local/lib/R/lib/
#> LAPACK: /usr/local/lib/R/lib/
#> locale:
#>  [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
#>  [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
#>  [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8   
#>  [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
#>  [9] LC_ADDRESS=C               LC_TELEPHONE=C            
#> attached base packages:
#> [1] stats     graphics  grDevices utils     datasets  methods   base     
#> loaded via a namespace (and not attached):
#>  [1] knitr_1.37        magrittr_2.0.1    R.cache_0.15.0    rlang_0.4.12     
#>  [5] fastmap_1.1.0     fansi_1.0.2       stringr_1.4.0     styler_1.6.2     
#>  [9] highr_0.9         tools_4.1.0       xfun_0.29         R.oo_1.24.0      
#> [13] utf8_1.2.2        withr_2.4.3       htmltools_0.5.2   ellipsis_0.3.2   
#> [17] yaml_2.2.1        digest_0.6.29     tibble_3.1.6      lifecycle_1.0.1  
#> [21] crayon_1.4.2      purrr_0.3.4       R.utils_2.10.1    vctrs_0.3.8      
#> [25] fs_1.5.2          glue_1.6.1        evaluate_0.14     rmarkdown_2.11   
#> [29] reprex_2.0.1      stringi_1.7.6     compiler_4.1.0    pillar_1.6.5     
#> [33] backports_1.4.1   R.methodsS3_1.8.1 pkgconfig_2.0.3

R version 4.1.2 (2021-11-01)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 19042)

Matrix products: default

[1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United States.1252 LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C LC_TIME=English_United States.1252
system code page: 65001

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_4.1.2 tools_4.1.2

I guess I also want to know if rattle is getting obsolete as one of the packages that it needs has been archived in CRAN

Even ancient Greek isn't yet obsolete, but it is fading. See this link for an alternative way to install dependencies.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.