Cannot install packages("mlogit")

> install.packages("mlogit")
WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:
Installing package into ‘C:/Users/Sarah Zhang/Documents/R/win-library/3.5’
(as ‘lib’ is unspecified)
Warning in install.packages :
  dependency ‘Rdpack’ is not available

  There is a binary version available but the source version is later:
       binary source needs_compilation
mlogit  1.0-1  1.0-3             FALSE

installing the source package ‘mlogit’

trying URL ''
Content type 'application/x-gzip' length 713459 bytes (696 KB)
downloaded 696 KB

ERROR: dependency 'Rdpack' is not available for package 'mlogit'
* removing 'C:/Users/Sarah Zhang/Documents/R/win-library/3.5/mlogit'
Warning in install.packages :
  installation of package ‘mlogit’ had non-zero exit status

You are missing this package dependency, try installing it first, do you get any error message?


Do you install Rtools package?

Hi, yes, I tried that before, but it does not work. I just uninstalled R and download everything again. And the "mlogit" works now. Thank you.

Hi, I install "Rdpack" before and did get error message. It does not work. Then I just uninstalled R and download everything again. Now the "mlogit" works. Thank you.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.