Cannot Install Package tidypaleo

Sorry I am a noob. Trying to insta package from github on macos-el capitan

# install.packages("remotes")

and getting error:

Error: Failed to install 'tidypaleo' from GitHub:
(converted from warning) unable to access index for repository
cannot open URL ''

I am not behind a firewall and unchecked "use secure download method for http" in universal settings.
So if this is trying to download right from github why is it trying to connect to cran. I don't this package is in the cran repository.

Please help.
Thank you,

Hi, and welcome!

Please see the FAQ: What's a reproducible example (`reprex`) and how do I do one? Using a reprex, complete with representative data will attract quicker and more answers. Not necessary for this question, however.

Very few packages are standalone, and tidypaleo is not exception. The description file shows a ton of packages that it relies on. These are dependencies.

So, this happened because the install for the package tried to install the dependencies, as well.

The immediate reason is that the R configuration file on your page pointing to is trying to open a 404 (not found) page.

If you are installing within RStudio, see the configuration guide. If you are using the MAC R GUI, see the Packages & Data | Install and choose another repository.

However, you'd save future trouble by updating from R.3.5 to 3.6.

Finally, if you run across "source version is later" and respond "yes," install from source, if it doesn't install the first time, there's nothing to be done by most users, because it requires editing the underlying source code to run on Apple's non-standard compiler.

Hello technocrat,

Thank you for your reply. I updated to 3.6.
And then changing the repository from the global to the nearest location in the USA allowed for a successful installation.

So that's interesting that the ability to install is dependent on the proximity of the mirror to the user?It sounds more akin to a radio transmission. Why is that?

Thanks so much!

1 Like

Glad that worked. The CRAN site hiccuped today. Should be back to normal soonish, based on last time

Is not about proximity, but to a lag in synchronization among CRAN mirrors, the one in the USA you selected is already up to date.


Ok, so the default is the global, so if that is giving you trouble you can just simply exhaustively go down the list till you get to a mirror that is up to date?

It's always a good idea to choose the nearest strong mirror, simply because of network congestion problems, which don't necessarily confine themselves to plague years. The RStudio default, is reasonably robust.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.