Cannot install dev tidyr from GitHub

Pretty simple question. Failed to install tidyr package. A similar problem was here, but the topic is closed.

My error

Downloading GitHub repo tidyverse/tidyr@master
√ checking for file 'C:\Users\wb516241\AppData\Local\Temp\Rtmpcru0Oo\remotes57d05f004484\tidyverse-tidyr-a3431e3/DESCRIPTION' (844ms)

  • preparing 'tidyr': (1.3s)
    √ checking DESCRIPTION meta-information ...
  • cleaning src
  • installing the package to process help pages (595ms)
  • cleaning src (41.6s)
  • checking for LF line-endings in source and make files and shell scripts (500ms)
  • checking for empty or unneeded directories
  • looking to see if a 'data/datalist' file should be added
  • building 'tidyr_0.8.99.9000.tar.gz'

Installing package into ‘C:/Users/wb516241/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)
ERROR: failed to lock directory 'C:/Users/wb516241/Documents/R/win-library/3.6' for modifying
Try removing 'C:/Users/wb516241/Documents/R/win-library/3.6/00LOCK-tidyr'
Error: Failed to install 'tidyr' from GitHub:
(converted from warning) installation of package ‘C:/Users/wb516241/AppData/Local/Temp/Rtmpcru0Oo/file57d014f133d3/tidyr_0.8.99.9000.tar.gz’ had non-zero exit status

Tried multiple solutions, but no luck.

R version 3.6.1 (2019-07-05)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 17134)

Matrix products: default

[1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United States.1252
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C
[5] LC_TIME=English_United States.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] Rcpp_1.0.2 ps_1.3.0 prettyunits_1.0.2 rprojroot_1.3-2 withr_2.1.2 digest_0.6.20
[7] crayon_1.3.4 assertthat_0.2.1 R6_2.4.0 backports_1.1.4 magrittr_1.5 rlang_0.4.0
[13] cli_1.1.0 curl_4.0 fs_1.3.1 remotes_2.1.0 rstudioapi_0.10 callr_3.3.1
[19] desc_1.2.0 devtools_2.1.0 tools_3.6.1 glue_1.3.1 pkgload_1.0.2 compiler_3.6.1
[25] processx_3.4.1 pkgbuild_1.0.4 sessioninfo_1.1.1 memoise_1.1.0 usethis_1.5.1

Any ideas appreciated.

Have you tried removing the file it suggests in the error message?

Try removing 'C:/Users/wb516241/Documents/R/win-library/3.6/00LOCK-tidyr'


Thanks, I think we can close the topic :slight_smile:

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

Done, thanks. Marked Mara's recommendation as solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.