Cannot download plm package

I am trying to install plm package for a while, and always get error message. I have installed R tools 4.0 and package collapse (as required in the error message), but I still get the following error message. It says it needs collapes version 1.6.0. I have tried to update it but it does not work.

THANK YOU for your help, I am a bit desperate!

WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:

Installing package into ‘C:/Users/celine.renucci/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)
also installing the dependency ‘collapse’

There are binary versions available but the
source versions are later:
binary source needs_compilation
collapse 1.5.3 1.7.6 TRUE
plm 2.4-1 2.6-1 FALSE

Binaries will be installed
trying URL ''
Content type 'application/zip' length 3842937 bytes (3.7 MB)
downloaded 3.7 MB

package ‘collapse’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
installing the source package ‘plm’

trying URL ''
Content type 'application/x-gzip' length 1652371 bytes (1.6 MB)
downloaded 1.6 MB

  • installing source package 'plm' ...
    ** package 'plm' correctement décompressé et sommes MD5 vérifiées
    ** using staged installation
    ** R
    ** data
    ** inst
    ** byte-compile and prepare package for lazy loading
    Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) :
    namespace 'collapse' 1.5.3 is being loaded, but >= 1.6.0 is required
    Calls: ... namespaceImportFrom -> asNamespace -> loadNamespace
    Exécution arrêtée
    ERROR: lazy loading failed for package 'plm'
  • removing 'C:/Users/celine.renucci/Documents/R/win-library/3.6/plm'
    Warning in install.packages :
    installation of package ‘plm’ had non-zero exit status

The downloaded source packages are in

RTools40 is to be used with R >= 4.0.0, for your old R version you can download the proper Rtools version from here

Although, I would recommend updating your R version so you can get access to precompiled binaries that are easier to install

Thank you very much, it worked!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.