Cannot access Rstudio server (open source) from browser

I believe I have successfully installed the Rstudio-Server open source. However I cannot access it from the browser.
R version and server info are:
R version 4.0.2 (2020-06-22)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Red Hat Enterprise Linux 8.3 (Ootpa)

When I ran sudo rstudio-server verify-installation, I didn't get any message.
When I ran sudo Rstudio-server status, I got this:

● rstudio-server.service - RStudio Server
Loaded: loaded (/usr/lib/systemd/system/rstudio-server.service; enabled; vendor preset: disabled)
Active: active (running) since Thu 2021-05-06 12:54:14 EDT; 1h 7min ago
Main PID: 2651821 (rserver)
Tasks: 3 (limit: 3355442)
Memory: 17.6M
CGroup: /system.slice/rstudio-server.service
└─2651821 /usr/lib/rstudio-server/bin/rserver

I tried to access R studio from browser: http://servername:8787. It always have the ERR_CONNECTION_TIMED_OUT.

I have access to Rstudio server on a different machine. So I guess it is probably some setting on the new server.
I have been googling and tried several things, but none worked.
I tired ufw allow 22 and ufw allow 8787
I tried the sudo netstat -anp | grep 8787
here is the output:
tcp 0 0* LISTEN 2651821/rserver

Another thing that might help to figure out the problem is that when I tried to obtain the public key before installation (gpg --keyserver --recv-keys 3F32EE77E331692F), I always get the time out error too. So I skipped this step.

I don't have much knowledge on the computer setups, cannot figure out where the problem is.
Any advice would be good.

Have you checked if you can access RStudio Server from within your local network? With local_server_ip:8787

Does your server has its own exclusive public IP? If not have you configured port forwarding in your router?

Thank you. The problem solved.
I have asked the IT department to enable 8787 port on local network, then I can access to the Rstudio Server log in page.
Then I did "cp /etc/pma.d/login /etc/pam.d/rstudio". Now I have access to the RStodio server.
Thank you!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.