Cannot access RStudio IDE instance using Conda Environment

Hello Experts.

I am getting the following error when I try to load the reticulatepackage I built in a local conda environment:

Error: package or namespace load failed for ‘reticulate’ in dyn.load(file, DLLpath = DLLpath, ...):
 unable to load shared object '~/Gits/nlp_r_in_python_testing/nlp_py_env/lib/R/library/reticulate/libs/':
  /lib64/ version `GLIBCXX_3.4.20' not found (required by ~/Gits/nlp_r_in_python_testing/nlp_py_env/lib/R/library/reticulate/libs/

The RStudio instance just seems to keep defaulting to the server base. Even happens with the library paths:

.libPaths(c("./nlp_py_env/lib/R/library", "./nlp-modeling/renv/library/R-4.2/x86_64-pc-linux-gnu"))
> .libPaths()
[1] "./nlp_r_in_python_testing/nlp_py_env/lib/R/library"
[2] "/opt/R/4.2.1/lib/R/library"

The same error described in the posts here:

And in this previous topic:

The workaround to this (proposed in the first link) seems fairly straightforward.

However, I don't quite understand how to call the RStudio IDE from my browser.
Specifically, if I should use the format :<port#>, or :<port#>, as neither seem to have worked.

Any guidance or suggestions would be greatly appreciated!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.