Can you reproduce? RStudio crashes while trying to open RCommander (Rcmdr)

RStudio crashes every time I run library(Rcmdr)(R Commander, version 2.7-2) in RStudio (I used the current stable release and 2022.7.0.545 preview) on Windows 10 and R 4.2.0. The same issue in both. The package should open GUI written in TCL-TK. I tried examples from tcltk package and they worked. I updated all packages from CRAN. When I use R GUI, the package Rcmdr opens as expected.

  1. Windows users, can you reproduce the error?
  2. How to debug this error? Is there a solution?

    RStudio Edition : Desktop [Open Source]
    RStudio Version : 2022.7.0.545
    OS Version      : Windows 10 x64 (build 19044)
    R Version       : R version 4.2.0 (2022-04-22 ucrt)

I tried to reinstall RStudio and to reset the RStudio state (remove folders) as described here: It did not help.

I tried installing Rcmdr 2.6-2 and 2.5 – It did not help.

I tried switching to R 4.1.3 with (Rcmdr 2.7-2 and RStudio 2022.7.0.545 preview). Now it works.

Rcmdr doesn't currently support the latest versions of RStudio. It is up to Rcmdr's developers to implement compatibility if they decide to do so. This is not related to the RStudio IDE.

I updated to R 4.2.1 and the problem seems to be solved there.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.