Can not install dplyr on R 3.5 running on linux server

When trying to install dplyr I get the following error message:

> install.packages("dplyr")
Installing package into ‘/data/R/baXXXXX/R/x86_64-suse-linux-gnu-library/3.5’
(as ‘lib’ is unspecified)
trying URL ''
Content type 'application/x-gzip' length 1173098 bytes (1.1 MB)
downloaded 1.1 MB

* installing *source* package ‘dplyr’ ...
** package ‘dplyr’ successfully unpacked and MD5 sums checked
** libs
g++  -I"/usr/lib64/R/include" -DNDEBUG -I../inst/include -DRCPP_DEFAULT_INCLUDE_CALL=false -DCOMPILING_DPLYR -DRCPP_USING_UTF8_ERROR_STRING -DRCPP_USE_UNWIND_PROTECT -DBOOST_NO_AUTO_PTR  -I"/data/R/baXXXXX/R/x86_64-suse-linux-gnu-library/3.5/BH/include" -I"/data/R/baXXXXX/R/x86_64-suse-linux-gnu-library/3.5/plogr/include" -I"/data/R/baXXXXX/R/x86_64-suse-linux-gnu-library/3.5/Rcpp/include" -I/usr/local/include   -fpic  -fmessage-length=0 -grecord-gcc-switches -fstack-protector -O2 -Wall -D_FORTIFY_SOURCE=2 -funwind-tables -fasynchronous-unwind-tables  -c RcppExports.cpp -o RcppExports.o
In file included from ../inst/include/dplyr_types.h:5:0,
                 from RcppExports.cpp:5:
../inst/include/dplyr/data/DataMask.h:13:32: fatal error: boost/shared_ptr.hpp: No such file or directory
 #include <boost/shared_ptr.hpp>
compilation terminated.
/usr/lib64/R/etc/Makeconf:168: recipe for target 'RcppExports.o' failed
make: *** [RcppExports.o] Error 1
ERROR: compilation failed for package ‘dplyr’
* removing ‘/data/R/baXXXXX/R/x86_64-suse-linux-gnu-library/3.5/dplyr’
Warning in install.packages :
  installation of package ‘dplyr’ had non-zero exit status

The downloaded source packages are in

Here is some session info:

platform x86_64-suse-linux-gnu
arch x86_64
os linux-gnu
system x86_64, linux-gnu
major 3
minor 5.0
year 2018
month 04
day 23
svn rev 74626
language R
version.string R version 3.5.0 (2018-04-23)
nickname Joy in Playing

I am not an expert in the inner working of dplyr :package: but perhaps I have an idea:

This seems to be the issue, so start by trying to install the boost libraries on your system:

If the library is already installed it may be a linking problem...


1 Like

Thanks for the answer!
I tried to install boost, but got the message that it is not available for R 3.5. I have now done a work-around and copied the installed library from a coworker into my Folder. That worked, although it doesnt really solve the Problem.

Boost is not an R package, is a library you have to install in your system not in R, check the link courtiol gave you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.