bookdown failing to render book

I'm editing a bookdown book, hosted in this repo:

When I run bookdown::render_book(), I get this error message, that has baffled me for the past hour:

When I run, bookdown::serve_book(), I get another similar error message:

Does anyone know what's going on?

In split_chapters(output = output, build = function(...) bs4_book_page(...,  :
  You have 11 Rmd input file(s) but only 10 first-level heading(s). Did you forget first-level headings in certain Rmd files?

the name message. In both cases, however, the html renders correctly. This is from the unmodified repo as of the first commit.

So, what has changed since then, if anything? Otherwise, I figure it's a configuration problem with the rendering toolchain.

I thought it'd be easier to just make a whole new repo for the book, and did that. Thanks for the help, @technocrat .

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.