Bookdown Document Not Rendering Outputs Correctly


I have a bookdown document that renders fine on my local machine, but when I have it run as an automated process using GitHub Actions the outputs from the individual code chunks show up all jumbled up:

This is the GitHub repository for the book: GitHub - ries9112/cryptocurrencyresearch-org: Repository that updates an R tutorial every 12 hours (see link below)

And here are where the automated runs through GitHub Actions are running: Workflow runs · ries9112/cryptocurrencyresearch-org · GitHub

In order to help troubleshoot the problem, I created a separate repository as a much more barebones example, and I am running into the exact same issue. Here is the repository for the simpler example: GitHub - ries9112/bookdown-test: Test repository to figure out output issue

I deployed the results from that simpler test and you can find them here: 2 Introduction | A Minimal Book Example

The documents format totally fine locally, so looks like there may be something else that I need to install, but I am currently installing pandoc and tinytex, and I can't figure out what else may be missing. Here is the YAML file that defines the GitHub Action:

    runs-on: macOS-10.15
      - uses: actions/checkout@v2
      - uses: r-lib/actions/setup-r@v1
      - name: Install pandoc and pandoc citeproc
        run: |
          brew install pandoc
          brew install pandoc-citeproc
      - name: Install Packages
        run: |-
          Rscript -e "install.packages(c('pins','bookdown','tidyverse','DT'))"
      - name: Refresh book
        run: |-
          Rscript -e "bookdown::render_book('index.Rmd', 'bookdown::gitbook')"

Any thoughts on any anything that may be missing in those installation steps to get this to render correctly? I have tried on Ubuntu and Windows as well and ran into the same problems.

I also tried these steps for pandoc and tinytex install and ran into the same exact problem:

      - uses: r-lib/actions/setup-pandoc@v1
      - uses: r-lib/actions/setup-tinytex@v1

Would really appreciate any thoughts on how to fix the issue!

Also posted to stackoverflow and will update both with the answer if one is found.

1 Like


I answered in Stackoverflow:

And also in your tweet this morning:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.