Blogdown serve_site, page could not load

I have some problems creating my website using the theme hugo-apero. When I change something in config.toml the page could not load, with error:

Failed to reload config: "D:\ComputationalTool\RStudy\congwang\hugo_apero\config.toml:10:42": unmarshal failed: toml: invalid character in comment .

Even if I undo the changes and return to the original, there will be the same error. I could not reload the page anyhow.

Here is the screenshot:

Here are some supplements for the problem, when I call the package "blogdown", here is the warning message:
Warning message:
In read_utf8(file) :
The file config.toml is not encoded in UTF-8. These lines contain invalid UTF-8 characters: 10

So I think maybe that is the problem, but I still don't know how to solve it.

It seems the special character you have on line 10 at the end in the comment is causing the issue.
Can you try remove the comment at the end of line 10 and see if that helps ?

Thanks cderv, it is very silly, the problem is solved by removing the strange comment in line 10, it seems like R put it there automatically.

The line comes from

and it seems the character got change somehow on your system to another one.

What happens is that during the installation by blogdown the file got downloaded / copied to your installation path, and somehow transformed. (maybe your are not using UTF-8... :thinking: )

Maybe it is an issue with blogdown too...

So maybe you won't be the only one with the same issue.

Would you like to report it on the repo Issues · hugo-apero/hugo-apero · GitHub ?

You can tag me @cderv and copy some of the above.


In fact I see you already have:

Please next time, share links when you cross post

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.