BiocManager::install(version="3.14") - I am trying to install Sleuth/getting dll: Permission denied

Here is my entire code:

if (!require("BiocManager", quietly = TRUE))
BiocManager::install(version = "3.14")




When I run just:

if (!require("BiocManager", quietly = TRUE))
BiocManager::install(version = "3.14")

I get in the console:

if (!require("BiocManager", quietly = TRUE))

  • install.packages("BiocManager")

BiocManager::install(version = "3.14")
'getOption("repos")' replaces Bioconductor standard repositories, see '?repositories' for

replacement repositories:

Bioconductor version 3.14 (BiocManager 1.30.16), R 4.1.1 (2021-08-10)
Installation paths not writeable, unable to update packages
path: C:/Program Files/R/R-4.1.1/library
class, foreign, lattice, MASS, Matrix, mgcv, nlme, nnet, rpart, spatial, survival
Old packages: 'cli'
Update all/some/none? [a/s/n]:

I type "a" into console and get:

trying URL ''
Content type 'application/zip' length 1257150 bytes (1.2 MB)
downloaded 1.2 MB

package ‘cli’ successfully unpacked and MD5 sums checked
Warning: cannot remove prior installation of package ‘cli’
Warning: restored ‘cli’

The downloaded binary packages are in
Warning message:
In file.copy(savedcopy, lib, recursive = TRUE) :
problem copying C:\Users\foste\Documents\R\win-library\4.1\00LOCK\cli\libs\x64\cli.dll to C:\Users\foste\Documents\R\win-library\4.1\cli\libs\x64\cli.dll: Permission denied

What in the world is going on? HELP! Thanks.

You need to run RStudio as administrator to be able to install into this folder.

Thanks for responding. I've tried fixing this and giving myself full access through the security options and I just can't figure it out. Could you share any more details?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.