Arcgis not loading in Rstudio

I'm having problems loading arcgisbinding in Rstudio, while it's working in normal R:

In Rstudio:

Error: package or namespace load failed for ‘arcgisbinding’:
.onLoad failed in loadNamespace() for 'arcgisbinding', details:
call: inDL(x, as.logical(local), as.logical(now), ...)
error: Failed to load 'libobjects_pro.dll'

In R:

*** Please call arc.check_product() to define a desktop license.

The latter is how it should work. Any ideas?

I should add that I'm running Rstudio Version 1.2.5001 and R 3.6.1 64 bit on Windows 10 Enterprise version 1809. I've tried to reinstall the arcgisbinding, Rstudio and R multiple times, but I'm reluctant to reinstall Arcgis Pro. Anyways it seems the problem is specific to Rstudio.

Hi it seems this problem goes beyond Rstudio. I was testing the connection from within normal R and both and arc.write produce similar errors eg.:

arc.write(path = 'C:\Users\user\Documents\ArcGIS\Projects\dummy_template\dummy.gdb\Data', data = datadf, overwrite = TRUE)
Error in .call_proxy("arc_write", path, pairlist(data = data, coords = coords, :
insert row failed

It looks like there are bugs in the latest version of arcgisbinding. You can try the previous v232 version. I had the same error as yours with the latest 235 version. I replaced the arcgisbinding library folder with v232 and the errors are gone.

Thank you:) I had a look at the R-Arcgis site at github when I realized this was not specific to RStudio. The same solution was suggested there, which worked. So this is solved by this workaround.

Hello atle,

We've identified the issue between newer versions of RStudio and our v235 release, and are working on a new version of the package that fixes this (and makes other improvements). I'll update this thread once it is up on GitHub.

Cheers, Shaun

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.