Annobin problem in package installation

I am trying to do a normal instal.packages("tidyverse")

I get a lot of those errors:

cc1: error: unrecognized command line option '-fstack-clash-protection'
cc1: error: unrecognized command line option '-fcf-protection'
cc1: fatal error: inaccessible plugin file /home/messner/Bin/Anaconda/bin/../lib/gcc/x86_64-conda_cos6-linux-gnu/7.3.0/plugin/ expanded from short plugin name annobin: No such file or directory
compilation terminated.
make: *** [/usr/lib64/R/etc/Makeconf:168: dots.o] Error 1
ERROR: compilation failed for package ‘ellipsis’
* removing ‘/home/messner/R/x86_64-redhat-linux-gnu-library/4.1/ellipsis’
Linux hal 5.15.12-200.fc35.x86_64 #1 SMP Wed Dec 29 15:03:38 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

platform       x86_64-redhat-linux-gnu     
arch           x86_64                      
os             linux-gnu                   
system         x86_64, linux-gnu           
major          4                           
minor          1.2                         
year           2021                        
month          11                          
day            01                          
svn rev        81115                       
language       R                           
version.string R version 4.1.2 (2021-11-01)
nickname       Bird Hippie 

As a Python package manager Anaconda is brilliant. However, I've seen far many more reports of problems using it for R than I have reports of success.

Thank you ... I have now tried to remove it with:

conda remove "r-*"

So far so good.

1 Like

It works now, after removing conda R stuff :wink:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.