After installing Rstudio on linux server, cannot access in browser

(I tried to delete this post but was not permitted to do so. I was able to solve the problem. The issue was that I had not properly opened up port 8787. After openning port 8787 I was able to access Rstudio in my browser.)

I have installed both R and Rstudio on a Linux (Red Hat) server. When I attempt to visit in my browser
http://[server-ip]:8787 (replacing 'server.ip' with my actual public ip) I get a timeout error in the browser.

I tried running sudo rstudio-server verify-installation which does not provide any output, after entering my password the cursor just moves to the next line ready for new commands.

R version 3.5.0 (2018-04-23)
Platform: x86_64-redhat-linux-gnu (64-bit)
Running under: CentOS Linux 7 (Core)

Matrix products: default
BLAS/LAPACK: /usr/lib64/R/lib/

 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.5.0

I've tried sudo rstudio-server restart which returned a message "no process found".
I then tried sudo rstudio-server start I don't know if this did anything since no message was received, after hitting enter I was taken to the next line and the terminal was ready for the next command.

I followed the download instructions here:
$ wget
$ sudo yum install rstudio-server-rhel-1.1.456-x86_64.rpm

How can I check if Rstudio server is running? Not sure what other information to provide?

1 Like