1st shiny app not uploading "kable package not available"

Hi, first shiny app which I am trying to load onto shinyapp.io server.

I had problems with my own app but have the same problem with the old faithful geyser template.

When I try run deployApp(), then it gives me the following error:

Preparing to deploy application...DONE
Uploading bundle for application: 8122435...Error: Unable to retrieve package records for the following packages:
- 'kable'
In addition: Warning message:
In FUN(X[[i]], ...) :
  Package 'kable' not available in repository or locally


Installing package into ‘/Users/brianbrummer/Library/R/x86_64/4.2/library’
(as ‘lib’ is unspecified)
Warning in install.packages :
  package ‘kable’ is not available for this version of R

A version of this package for your version of R might be available elsewhere,
see the ideas at

For me, this doesn't make sense, since kable isn't even a package? I have tried loading kableExtra, Knitr, I have tried loading kable on older versions of R but without success.

Any suggestions?

the error on deployApp that you quoted here; thats on the old faithful geyser template; without any modifications ?

no modifications, simply adding setAccountInfo() and then deployApp()

> sessionInfo()
R version 4.2.2 (2022-10-31)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Catalina 10.15.7

do you have this in its own folder as a project ?
if not .. you should...
if you do ; what is the result of rsconnect::appDependencies()

       package version source
1           R6   2.5.1   CRAN
2         Rcpp   1.0.9   CRAN
3    base64enc   0.1-3   CRAN
4        bslib   0.4.2   CRAN
5       cachem   1.0.6   CRAN
6          cli   3.6.0   CRAN
7   commonmark   1.8.1   CRAN
8       crayon   1.5.2   CRAN
9       digest  0.6.31   CRAN
10    ellipsis   0.3.2   CRAN
11     fastmap   1.1.0   CRAN
12 fontawesome   0.4.0   CRAN
13          fs   1.5.2   CRAN
14        glue   1.6.2   CRAN
15   htmltools   0.5.4   CRAN
16      httpuv   1.6.8   CRAN
17   jquerylib   0.1.4   CRAN
18    jsonlite   1.8.4   CRAN
19       later   1.3.0   CRAN
20   lifecycle   1.0.3   CRAN
21    magrittr   2.0.3   CRAN
22     memoise   2.0.1   CRAN
23        mime    0.12   CRAN
24    promises   CRAN
25    rappdirs   0.3.3   CRAN
26       rlang   1.0.6   CRAN
27        sass   0.4.4   CRAN
28       shiny   1.7.4   CRAN
29 sourcetools   0.1.7   CRAN
30       withr   2.5.0   CRAN
31      xtable   1.8-4   CRAN

Hi, i started a new project in a new file and it looks like they geyser data went through fine.

I guess I should be more careful. I will start a new project and see if my own app will run aswell now.

Thanks for indulging me so far

Does your app (or any sourced .R scripts that may be called) contain"library(kable)" or "kable::"? Sourced scripts can sometimes hide errors like these, so just thought I'd ask.

Thanks for the pointer, I am sure some Rmakrdowns have kable:: in them. I'll have to go through...for now, I am atleast moving again...

1 Like